Troubleshooting: Airtable Source

Most common issues with Airtable source

Shared view URL appears to be a shared base URL error

This must be a valid shared view URL error

The current view is shared only to a specific domain error

Request failed with status code 403 error

Shared view URL appears to be a shared base URL error

Issue description

With Coupler.io, you can import the Airtable shared view data.


If you paste the link to the whole Airtable base instead of a single shared view URL, you will receive the "Cannot access data: shared view URL appears to be shared base URL" notification during data loading for preview:

How to fix the issue

Here's the quickest way to receive a link to a specific shared view: 

  • Navigate to the Airtable view that you want to share.
  • Click the "Share and sync" button.
  • Click the "Create link to view" button.
  • Copy the link and make sure that the "Allow viewers to copy data out of this view" toggle is on (otherwise, you won’t be allowed to import data from this view).

This must be a valid shared view URL error

Issue description

With Coupler.io, you can import the Airtable shared view data. If you paste anything but a valid shared view link (eg, an invite link to the base), you will receive the "This must be a valid shared view url" notification during your source setup in Coupler.io wizard:

How to fix the issue

Please use a valid shared view URL from Airtable. Here's how to get it.


The current view is shared only to a specific domain error


Issue description

Coupler.io supports importing data from Airtable views that are password-protected.

Airtable also allows to restrict access to the view by a specific email domain - unfortunately, Coupler.io doesn't support this restriction.

If the Airtable view you are importing is restricted by an email domain, rather a password (or by domain and password both), then you will receive the “Cannot access data: the current view is shared only to a specific domain" error notification. 


Request failed with status code 403 error


Possible causes

  • using an incorrect URL (eg a shared form URL, instead of a shared view)
  • using a view URL with protection by domain (we only support views with protection by password)
  • entering an incorrect password to the view protected by password

Troubleshooting

  • Please ensure you're using the correct shared view link from Airtable. Here's how to get it.
  • If your view is protected, please check that it only has protection by password, and not by domain. Views protected by a domain can not be imported with Coupler.io currently.
  • If your view is protected by password, please ensure you are entering the correct password.

If any of the steps above do not help resolve the issue, please reach us at contact@coupler.io, we'll be happy to assist!

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